Home

   Log in or Register



Insurance Quotes
forums Campsite Search Comp Directory tips virtual brochure Profile
Tent and Awning Reviews Competitions Caravans and Motorhomes For Sale Shopping Diary Contact Us

Advertisement

Message Forums

Welcome Guest Register Login Search The Forum Posts Since Last Visit
 Reception - All Forums
   Caravans and Caravanning -  Caravan Repairs, Servicing and Maintenance
Share   Tweet This!  Share on Facebook  Email  Printer Friendly Version Print
Subject Topic: Thetford Toilet Help Post Reply Post New Topic
Message posted by Dave11 via mobile 11/4/2022 at 11:16pm
Outfit:  Swift 645 Elegance - Range Rover Sport     Location:  Sussex
Joined: 11/7/2005
View Dave11's Profile View Profile   Reply to Dave11 Reply   Quote Dave11 Quote  
Dave11
Avatar
Platinum Member
Platinum Member

Forum Posts:   828

Site Reviews Total: 1
Site Reviews 2022: 0  
Site Reviews 2021: 0  
Site Reviews 2020: 0  
Site Reviews 2019: 0  
Site Reviews 2018: 0  
Site Nights 2022: 0
Site Nights 2021: 0
Site Nights 2020: 0
Site Nights 2019: 0
Site Nights 2018: 0

I have a 2019 Swift Elegance 645 fitted with the Thetford C262 CWE toilet and the flush suddenly stopped working whilst away.
I checked the pump and it was seized and managed to free the impeller with a screwdriver . After putting the pump back in , it still wouldnít work so bought a new pcb board that goes on top of the flush unit from a local caravan shop and for good measure bough a new reed board and replaced that in the cover behind the cassette .They hadnít got a new pump , so will have to wait until I get home to replace that too. Hereís the problem though, I am not now convinced that replacing the pump will cure the problem, as I filled the cassette with water and the red light didnít come on? My thoughts are that even if the pump wasnít working , the fact I replaced both boards for new ones surely the red light would still come on ?
The fuse on the main PSU must be working as it says it shares the fuse with appliances / hob ignition .
The hob spark is working , so it canít be the fuse in the PSU?
I can only assume there must be an inline fuse somewhere, but many people on various posts have asked in the past but seems have never had a conclusive answer?
Many have said itís at the back of the cassette box, but thatís on the C250 model , some have said it could be under the switch panel on top of the toilet , but itís not there either , does anyone know where the inline fuse would be on the C262cwe toilet as Iím now convinced there is no power going to the toilet ?
Thanks .

Message posted by kevin-t12/4/2022 at 6:27am
Outfit:  Coachman laser RangeRover Sport4.4     Location:  SHEFFIELD
Joined: 07/9/2010
View kevin-t's Profile View Profile   Reply to kevin-t Reply   Quote kevin-t Quote  
kevin-t
Avatar
Gold Member
Gold Member

Forum Posts:   310

Site Reviews Total: 3
Site Reviews 2022: 0  
Site Reviews 2021: 2  
Site Reviews 2020: 0  
Site Reviews 2019: 0  
Site Reviews 2018: 0  
Site Nights 2022: 0
Site Nights 2021: 21
Site Nights 2020: 0
Site Nights 2019: 0
Site Nights 2018: 0


Sorry I cannot help with the power side of things. However you do say that you have free'd the impeller..
I have to free mine very often after its been stood, only after a few weeks to be honest. What I have discovered is that the Impeller has to be really free spooling. I made the mistake of watching this video and assuming when loose it was ok.


https://youtu.be/k3Ei61L1gnk

It took several attempts with the screwdriver to get it really free spooling. However never fails, worth a check!
Best of luck.

Kevin-T........


Message posted by kpnuts8112/4/2022 at 8:26am
Outfit:  Gobur Clubman     Location:  Warwickshire
Joined: 18/7/2009
View kpnuts81's Profile View Profile   Reply to kpnuts81 Reply   Quote kpnuts81 Quote  
kpnuts81
Avatar
Platinum Member
Platinum Member

Forum Posts:   769

Site Reviews Total: 6
Site Reviews 2022: 0  
Site Reviews 2021: 1  
Site Reviews 2020: 0  
Site Reviews 2019: 1  
Site Reviews 2018: 1  
Site Nights 2022: 0
Site Nights 2021: 14
Site Nights 2020: 0
Site Nights 2019: 14
Site Nights 2018: 1

When my pump seized, I put mine into boiling water for a little time periodically pressing the flush and after about 5 minutes it freed up, I did this 2/3 times just to be sure before putting it back, I also cleaned a lot of the gunk inside of the flush tank as best I could through the hole where the pump fits, replaced the fuse in the cassette housing and all was fixed

Message posted by Dave11 via mobile 12/4/2022 at 8:34am
Outfit:  Swift 645 Elegance - Range Rover Sport     Location:  Sussex
Joined: 11/7/2005
View Dave11's Profile View Profile   Reply to Dave11 Reply   Quote Dave11 Quote  
Dave11
Avatar
Platinum Member
Platinum Member

Forum Posts:   828

Site Reviews Total: 1
Site Reviews 2022: 0  
Site Reviews 2021: 0  
Site Reviews 2020: 0  
Site Reviews 2019: 0  
Site Reviews 2018: 0  
Site Nights 2022: 0
Site Nights 2021: 0
Site Nights 2020: 0
Site Nights 2019: 0
Site Nights 2018: 0

If it still doesnít work after replacing the pump , I still canít find the where there is an inline fuse on the C262CWE model?
On the C250 model itís at the back of the toilet cassette compartment, but not on the C262CWE model ?

Message posted by blueexpo9712/4/2022 at 8:41am
Outfit:       Location:  
Joined: 07/2/2009
View blueexpo97's Profile View Profile   Reply to blueexpo97 Reply   Quote blueexpo97 Quote  
blueexpo97
Avatar
Diamond Member
Diamond Member

Forum Posts:   8617

Site Reviews Total: 23
Site Reviews 2022: 0  
Site Reviews 2021: 0  
Site Reviews 2020: 0  
Site Reviews 2019: 0  
Site Reviews 2018: 0  
Site Nights 2022: 0
Site Nights 2021: 0
Site Nights 2020: 0
Site Nights 2019: 0
Site Nights 2018: 0

Have you asked at the Sevice Dept. of your nearest Swift dealer?

Or any Swift dealer come to that.

-------------
XVI yes?

As well is two words!
How does a sage know everything about everything? or does he? or does he just think he does?
Remember, if you buy something you bought it, not brought it.

Advertisement


Message posted by kpnuts8112/4/2022 at 10:15am
Outfit:  Gobur Clubman     Location:  Warwickshire
Joined: 18/7/2009
View kpnuts81's Profile View Profile   Reply to kpnuts81 Reply   Quote kpnuts81 Quote  
kpnuts81
Avatar
Platinum Member
Platinum Member

Forum Posts:   769

Site Reviews Total: 6
Site Reviews 2022: 0  
Site Reviews 2021: 1  
Site Reviews 2020: 0  
Site Reviews 2019: 1  
Site Reviews 2018: 1  
Site Nights 2022: 0
Site Nights 2021: 14
Site Nights 2020: 0
Site Nights 2019: 14
Site Nights 2018: 1

My fuse was on the top of the cassette toilet compartment


In order to post a reply you will need to register, or if already registered please log in here

Prev       Next
Quick Links - All Forums - Caravan Repairs, Servicing and Maintenance - Top of Page

Printer Friendly Version Printable version      Share   Tweet This!  Share on Facebook  Email


Latest News, Discounts and Competitions  see all...





3347 Visitors online !

Free UKCampsite.co.uk Window Sticker  -  Recommend to Friend

[Message Forums]  [Caravan Sites & Camping]  [Company Listings]  [Features / Advice]  [Virtual Brochure]  [Shop!]
[Reception]  [Competitions]  [Caravans & Motorhomes For Sale]  [Event Diary]  [Contact Us]  [Tent Reviews



Please note we are not responsible for the content of external sites & any reviews represent the author's personal view only. Please report any error here. You may view our privacy and cookie policy and terms and conditions here. All copyrights & other intellectual property rights in the design and content of this web site are reserved to the UKCampsite.co.uk © 1999 - 2022


Advertisement


Advertisement